Warning The vulnerabilities PHP2Shell and HTTP2Shell are being heavily exploited right now. Many websites and servers are affected. Please check here first whether you are affected. Am I affected?

PHP2Shell What is PHP2Shell?

PHP2Shell is the name for two critical vulnerabilities in PHP (CVE-2026-109618 and CVE-2026-109619). They let an attacker run code on a web server without logging in. Since October 2026 they are being exploited in the wild.

Because the flaws are in PHP itself, almost every PHP application is affected as long as the PHP version is outdated. Fixed versions are PHP 8.2.35, 8.3.36, 8.4.27 and 8.5.12 or later.

Where does your company stand? The IT security check shows it in two weeks.

See the check, from €1,299

Contact

Free first call

Briefly describe your situation. We help you assess it and plan the next step. Reply within 24 hours on working days.

Dipl.-Ing. Samuel Ziegler, BScFounder

office [at] vetosec [dot] at